Configuration

The following steps will show how to configure the Data Links tool. This example will show you how to load information from your external data source (Excel spreadsheet) to your user-defined Properties tab.

STEP 1:

Go to the General Configuration tab in iConstruct menu and run the Data Links Configuration tool.

"Step 1"

STEP 2:

Select DataSource Type from the drop-down menu and search for a file in File Name.

"Step 2"

"Step 2"

Excel spreadsheet example.

STEP 3:

Define if you want to apply the information to Items or Groups or both (Apply to Object Types) and select a sheet where information is located in Excel (Select Table).

"Step 3"

STEP 4:

Select an element in the background model and click Get NW Props.

"Step 4"

STEP 5:

Choose Target Attribute – user defined tab where you will write the data or type in the name to create it.

"Step 5"

STEP 6:

Select Exists Action and Linking Attribute. Linking Attribute can be any tab that will define a connection between a database and a model.

"Step 6"

STEP 7:

Define linking property between the database and the model.

"Step 7"

NW Link Property and Database Link Field.

"Step 7"

STEP 8:

Check Fields to import.

"Step 8"

STEP 9:

Define Template Name and click Save.

"Step 9"

Quick Overview:

Go to Data Links Configuration ➤ Select DataSource Type ➤ Define Object Types ➤ Select Table ➤ Pick an item in the background ➤ Click Get NW Props ➤ Choose Target Attribute, Exists Action and Linking Attribute ➤ Define linking property ➤ Select Fields ➤ Save Template ➤ Close